logo

FAQ

Frequently Asked Questions

The FAQ page contains useful information collected during hands-on working sessions, which may help you solve some common issues encountered when working with Process Modeler.

FAQ

Error while loading the add-in
If you get an error while trying to enable the add-in in the Trust Center, try the following:

Check for correct bit version.

Make sure you have installed the correct bit version of the add-in. The bit version should always match the Visio bit version, not Windows. Follow this link to find out where you can find your Visio bit version.

Check your VSTO installation.

If the error reads something like "'C:\Program Files\itp-commerce\PM6\ITPcommerce.ProcessModeler.Visio2010Connect.vsto' is not a valid Office Add-in." you are most likely running an outdated or a wrong VSTO version. Download and install the required VSTO 4.0 (VS 2010/2012/2013) Runtime for Office 2007/2010/2013 from here.
Where do I find my Visio bit version?

Visio 2007 (and earlier)

Your Visio is 32-bit. There is no 64-bit version of Visio 2007.

Visio 2010

visio_2010_bit_version

Visio 2013

visio_2013_bit_version
No stencil

The Stencil is not shown after opening a BPD

After loading a diagram, the BPMN Stencil is not shown on the left hand side. This may look like this:

Solution

Open the Stencil manually through the menu: This will open the BPMN 2.0 Stencil.
Process documentation fails

Process documentation fails

Message Microsoft Word is not installed/could not be found

This message appears if the registry keys of Microsoft Office are not correctly registered in your systems registry. To correct this, up you need to  open the Registry Editor (start with the command "regedit"). and delete one or more entries. You need admin rights on your system to be able for this.

Solution

In the Registry you need to open the following node, below which you probably find more than one sub-node.: HKEY_CLASSES_ROOT\TypeLib\{00020905-0000-0000-C000-000000000046} These sub-nodes are named with e.g. 8.4 or 8.5. If you choose one of those you will be shown the entry "Standard" on the right hand. In the below picture you see "Microsoft Word 14.0 Object Library". This is the referenced Office Library with version number. Version numbers are as follows:
  • Office 2003 stands for version 11.0.0.0
  • Office 2007 stands for version 12.0.0.0
  • Office 2010 stands for version 14.0.0.0.
Reg-Key-Word Now you need to know which version of Microsoft Office is installed on your system and localize the respective node in the Registry. All other nodes must be deleted. With this operation you only affect the inter-operation of Office tools with Microsoft Word, i.e. you clean-up the inter-operation.

Cause

One cause for this problem is the installation of different versions of Microsoft Office. Once you install one version it writes a respective entry into the Registry. By de-installation this entry will not be deleted automatically. If you now install an older version of Microsoft Office you will find two entries in the registry, one for the old and one for the new. This indicates that a newer version of MS Office is installed and makes inter-operation between applications defective.
Themes and Effects

What about Themes and Effects?

Visio allows you to set so-called Themes and Effects for all shapes on a page. Process Modeler comes with some built-in Themes and Effects to help the user recolor and reshape the BPD. In the Design ribbon, click on the Colors item to apply another color set to your diagram (see picture below). This opens a task pane with a selection of various color schemes. To apply another effect scheme (e.g. to draw all shapes with rounded edges) click on Effects in the Theme ribbon. Available color schemes A right mouse click on the scheme you would like to apply shows you some options: Options when choosing a color scheme  
  • To apply a theme to the drawing on the current page only, right-click a thumbnail, and then click on Apply to Current Page.
  • To apply a theme to all pages, right-click a thumbnail, and then click Apply to All Pages.
This will set the Theme to all shapes in your drawing: Color scheme of the diagram is changed  
Change flow orientation

How do I change the flow orientation?

After the conversion from any other format (Visio, AML or just another BPMN diagram) it is necessary to change the flow orientation of the BPD. The following example was created from an external source (AML file) and has a "top–down" orientation after conversion to BPMN. The following steps will show you how to change the flow orientation in order to obtain a "horizontal" flow. Use the Process menu to change the layout: The following dialog will be displayed: Change-flow_en Finally, you will have to change the page size by using the Visio menu “File -> Page setup…”.
Converting BPMN 1.2 to 2.0

Will I lose data when converting a BPD from BPMN 1.2 to 2.0?

There are two different aspects related to this question:
  1. The BPMN model data
  2. Additional data outside the BPMN schema

The BPMN model data

The BPMN 1.2 schema (the so-called XML defined by itp-commerce and compliant to the OMG specification) has been replaced by the OMG’s official BPMN 2.0 XML schema. Besides the common translation of different schemas, the BPMN 2.0 specification also defines some new concepts and elements while disposing of others. Process Modeler will convert all BPMN 1.2 aspects to the BPMN 2.0 schema.

Additional data outside the BPMN schema

Some BPMN 1.2 features specific to Process Modeler are not yet supported in BPMN 2.0. As a consequence, some of the data cannot be converted or copied and may therefore be lost. This will include Repository References and Risks and Controls.
Documentation asks for file conversion

Documentation asks for File Conversion

After starting the documentation export to Microsoft Word, the process asks for some file conversion parameters. The dialogue appears for every BPMN element of your process. If you click ‘Cancel’ the documentation process will stop and no result is produced Solution
  1. Close Microsoft Word and make sure no instance of the application is still running.
  2. Open Microsoft Word again and go to the Options – Advanced – General.
  3. Disable the check box named with Confirm file format conversion on open
  4. Close the application and try to export to your process documentation again
  5. If this did not solve the problem, restart you computer and afterwards ensure, that the check box in the options dialogue of Microsoft Word is still unchecked. The documentation export should now work.
Visio 2003/2007: No “Process” menu

The "Process" menu is not visible in Visio 2003/2007

When starting Process Modeler using the shortcut in the Start menu, Visio will startup and a splash screen in the bottom right corner will inform the user that Process Modeler is loading. If you do not see the splash screen and if there is no "Process" menu in Visio either, there may be a problem with the installation of Process Modeler. To try solve this problem, please follow the steps below, referring to your version of Visio.

Microsoft Visio 2007

  1. Go to Help->About Microsoft Office Visio and check if there is a button Disabled Items.... If this is the case, click on that button and check if Process Modeler is listed. If it is listed, select it and press Enable. Restart Visio and see if it works. If not, also try the following step.
  2. Go to Tools->Trust Center.... Select Add-ins.
  1. Make sure that Disable all Application Add-ins is not enabled.
  2. Manage Disabled Items and select Go…. Check if Process Modeler is listed. If it is listed, select it and press Enable. Restart Visio and see if it works. If not, also try the following step.
  3. Manage COM Add-ins and select Go…. Make sure Process Modeler Addin is listed and that the checkbox is marked.If it is not checked, the addin has not loaded correctly the last time. Try to mark the checkbox, disable all unneeded add-ins and restart Visio. If the checkbox is again unmarked after the next restart of Visio, try to re-install Process Modeler

Microsoft Visio 2003

1. Go to Help->About Microsoft Office Visio and click the Disabled Items… button. If Process Modeler is listed, select it and press Enable. Restart Visio and see if it works. If not, also try the following step. 2. Check the security settings. To do so, go to Tools->Options…>Security. Enable COM add-ins and Enable Automation events should be enabled. 3. Check the registry to verify if the Addin is still enabled. To do so, Press Start->Run… on your Windows machine and enter "regedit" (admin rights required). Browse to the following Key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Visio\Addins\ProcessModelerVisioConnect.Connect and check if the LoadBehavior is set to 3. If it has a value of 2, the addin has not loaded successfully the last time. Try setting the value to 3 and restart Visio. If this entry does not exist or if the value changes back to 2 after the next restart of Visio, try to re-install Process Modeler. 4. If all the above did not help, check for other Add-ins and disable them. Go to Tools->Macros->COM Add-Ins…. uncheck every add-in (Please note that if the addin was running, there would still be no entry in the list for Process Modeler (Visio 2003 only)). If all the above failed, try to re-install Visio including the newest service packs and then re-install Process Modeler. If it is still not working, feel free to contact us at info (at) itp-commerce.com.
 
Visio 2010: No “BPMN” tab

The "BPMN" tab is not available in Visio 2010

Make sure the plugin is enabled

Click on File and select Options, then change to the Add-ins tab.
  1. Manage Disabled Items and select Go…. Check if Process Modeler is listed. If it is listed, select it and press Enable. Restart Visio and see if it works. If not, also try the following step.
  2. Manage COM Add-ins and select Go…. Make sure that Process Modeler Addin is listed and that the checkbox is marked. If it is not checked, the addin has not loaded correctly the last time. Try to mark the checkbox, disable all unneeded add-ins and restart Visio. If the checkbox is again unmarked after the next restart of Visio, try to re-install Process Modeler.
Connection to Oracle Repository fails

The connection to an Oracle Repository fails

In order to connect to an Oracle database, some additional drivers may be needed. If you already have a working Oracle client on your machine, you may start at step #3.
  1. From the Oracle website, download the ODAC client that supports your Oracle Database. For versions 9.2, 10.1, 10.2, 11.1, and 11.2 you may use the links below. The smaller packages with Xcopy Deployment will suffice:
  2. Install the ODAC client following the instructions provided within the download file ("readme"). Make sure to add the Oracle directories to the system PATH environment variable as indicated in the instructions.
  3. Navigate to the Oracle client directory into the "odp.net\bin\{versionNumber}" sub-directory. The path will look something like this: "%ORACLE_HOME%\product\11.2.0\client_1\ODP.NET\bin\2.x\".
  4. Copy the file "Oracle.DataAccess.dll"
  5. Open the Process Modeler installation directory. [Where is it?]
  6. Replace the existing "Oracle.DataAccess.dll" file with the one you have just copied from the Oracle directory.
  7. After restarting Visio you should be able to connect to the Oracle repository.
Error while loading the add-in

Error while loading the add-in

If you get an error while trying to enable the add-in in the Trust Center, try the following:

Check for correct bit version.

Make sure you have installed the correct bit version of the add-in. The bit version should always match the Visio bit version, not Windows. Follow this link to find out where you can find your Visio bit version.

Check your VSTO installation.

If the error reads something like "'C:\Program Files\itp-commerce\PM6\ITPcommerce.ProcessModeler.Visio2010Connect.vsto' is not a valid Office Add-in." you are most likely running an outdated or a wrong VSTO version. Download and install the required VSTO 4.0 (VS 2010/2012/2013) Runtime for Office 2007/2010/2013 from here.